Back to overview
Maintenance

Scheduled System Maintenance

Jun 15, 2026 at 10:00pm UTC  –  Jun 15, 2026 at 11:03pm UTC
Affected services
iOS and Android apps
Web App

Resolved
Jun 15, 2026 at 11:03pm UTC

Maintenance has been completed successfully and all services are operating normally.

We appreciate your patience during this maintenance window. If you experience any issues or notice anything unexpected, please contact us at support@areaofpeople.com and our team will be happy to assist.

Updated
Jun 15, 2026 at 10:26pm UTC

We have started scheduled maintenance on our infrastructure to improve performance and reliability. During this maintenance window, some services may be temporarily unavailable. We are actively monitoring progress and will provide updates as they become available.

Created
Jun 15, 2026 at 10:00pm UTC

We're carrying out infrastructure upgrades to enhance performance and reliability. The app and dashboard will be temporarily unavailable during this maintenance window. Thank you for your understanding!