Back to overview
Degraded

Increased Error Rate During Login

May 18, 2026 at 11:44am UTC
Affected services
Log in and accounts

Resolved
May 18, 2026 at 12:09pm UTC

The increased error rate affecting logins on the Area of People platform has been resolved. Users should now be able to sign in normally again.

We will continue to monitor the platform to ensure ongoing stability. If you are still experiencing login issues, please contact support@areaofpeople.com.

Created
May 18, 2026 at 11:44am UTC

We are currently investigating an increased error rate affecting logins on the Area of People platform. Some users may experience issues signing in or receive unexpected errors during authentication.

Our team is actively working to identify the root cause and restore full stability as quickly as possible.

We will provide another update shortly.