Some emails sent to @outlook.com addresses are experiencing delivery delays
Resolved
Jan 30 at 03:26pm CET
Earlier delays were caused by changes in delivery behaviour on Microsoft’s consumer email platform. Microsoft confirmed the issue was not isolated to our environment. After coordination with relevant providers, normal delivery speed has been restored. Please contact us if you are still experiencing issues at support@areaofpeople.com.
Affected services
Updated
Jan 29 at 02:59pm CET
We have acknowledgment from Microsoft about the change in delivery behavior on their consumer email platform. Microsoft has acknowledged that the behavior is not isolated to our environment
Affected services
Created
Jan 28 at 02:48pm CET
We are seeing slower-than-usual delivery for emails sent to @outlook.com domains. Messages are not lost, but may take longer to arrive than expected. Our team is actively investigating and working with relevant providers to restore normal delivery speeds as quickly as possible.
Affected services