Back to overview
Degraded

Login unavailable

May 27 at 01:27pm CEST
Affected services
Log in and accounts

Resolved
May 27 at 02:38pm CEST

The issue has been resolved. We sincerely apologise for the disruption. If you’re still experiencing any issues, please give it a moment or try refreshing your browser or app. Thank you for your patience and understanding.

Created
May 27 at 01:27pm CEST

The platform is currently unavailable for a small percentage of our users. This issue is related to an internal service disruption. Our team is actively working to resolve the problem, and we expect the platform to be fully operational shortly.